PDF Download is not working properly

Incident Report for Genially

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 13:35 UTC

Investigating

We are currently investigating this issue.
Posted Apr 01, 2025 - 09:38 UTC
This incident affected: View.