Unable to Import Google Slides into Genially

Incident Report for Genially

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 09:33 UTC

Investigating

Users are unable to import Google Slides into Genially. When attempting to do so, the process either fails to complete or the imported slides do not display correctly.
Posted Mar 17, 2025 - 17:16 UTC